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Preface
INTRODUCTION 
This chapter contains general information that will be useful to know before using the 
16-Bit 28-Pin Starter Development Board. Items discussed in this chapter include:
• Document Layout
• Conventions Used in this Guide
• Warranty Registration
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

DOCUMENT LAYOUT 
This document describes how to use the 16-Bit 28-Pin Starter Development Board as 
a development tool to emulate and debug firmware on a target board. The manual 
layout is as follows:
• Chapter 1. Introduction – This chapter introduces the 16-Bit 28-Pin Starter 

Development Board and provides a brief description of the hardware.
• Chapter 2. Tutorial – This chapter provides a step-by-step process for getting the 

16-Bit 28-Pin Starter Development Board up and running with the MPLAB® ICD 2 
in-circuit debugger.

• Chapter 3. Demonstration Program – This chapter describes the operational 
functionality of the sample code which is preprogrammed in the dsPIC33F device.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 
Select the Help menu, and then Topics to open a list of available on-line help files.
© 2008 Microchip Technology Inc. DS51656B-page 1
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• Chapter 4. Development Hardware – This chapter describes the hardware on 
the 16-Bit 28-Pin Starter Development Board.

• Appendix A. Drawings and Schematics – This appendix illustrates the hardware 
layout and schematic diagrams for the 16-Bit 28-Pin Starter Development Board.

• Appendix B. Bill of Materials (BOM) – This appendix lists the parts used in the 
16-Bit 28-Pin Starter Development Board.
DS51656B-page 2 © 2008 Microchip Technology Inc.
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CONVENTIONS USED IN THIS GUIDE
This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial font:
Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

‘bnnnn A binary number where n is a 
digit

‘b00100, ‘b10

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New font:
Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h
Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1
Italic Courier New A variable argument file.o, where file can be 

any valid filename
0xnnnn A hexadecimal number where 

n is a hexadecimal digit
0xFFFF, 0x007A

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}

© 2008 Microchip Technology Inc. DS51656B-page 3
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WARRANTY REGISTRATION 
Please complete the enclosed Warranty Registration Card and mail it promptly. 
Sending in the Warranty Registration Card entitles users to receive new product 
updates. Interim software releases are available at the Microchip web site.

RECOMMENDED READING
This user’s guide describes how to use the 16-Bit 28-Pin Starter Development Board. 
Other useful documents are listed below. The following Microchip documents are 
available and recommended as supplemental reference resources.
dsPIC30F Family Reference Manual (DS70046)
Refer this document for detailed information on dsPIC30F device operation. This 
reference manual explains the operation of the dsPIC30F DSC family architecture and 
peripheral modules, but does not cover the specifics of each device. Refer to the 
appropriate device data sheet for device-specific information.
dsPIC30F2010 Data Sheet (DS70118)
This data sheet summarizes the features of the dsPIC30F2010 and provides essential 
information needed to develop the software for this device.
dsPIC30F/33F Programmer’s Reference Manual (DS70157)
This manual is a software developer’s reference for the dsPIC30F/33F 16-bit DSC 
family of devices. It describes the instruction set in detail and also provides general 
information to assist in developing software for the dsPIC30F/33F DSC family.
dsPIC33FJ12MC201/202 Data Sheet (DS70265)
This data sheet summarizes the features of the dsPIC33FJ12MC201/202. It provides 
essential information needed to develop software for these devices.
PIC24HJ12GP201/202 Data Sheet (DS70282)
This data sheet summarizes the features of the PIC24HJ12GP201/202. It provides 
essential information needed to develop software for these devices.
PIC24FJ64GA004 Data Sheet (DS39881)
This data sheet summarizes the features of the PIC24FJ64GA004. It provides 
essential information needed to develop software for this device.
MPLAB® ASM30, MPLAB® LINK30 and Utilities User’s Guide (DS51317)
This document details Microchip Technology’s language tools for dsPIC® DSC devices 
based on GNU technology. The language tools discussed are:
• MPLAB ASM30 Assembler
• MPLAB LINK30 Linker
• MPLAB LIB30 Archiver/Librarian
• Other Utilities
DS51656B-page 4 © 2008 Microchip Technology Inc.
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MPLAB® C30 C Compiler User’s Guide (DS51284)
This document details the use of Microchip’s MPLAB C30 C Compiler for dsPIC DSC 
devices to develop an application. MPLAB C30 is a GNU-based language tool, based 
on source code from the Free Software Foundation (FSF). For more information about 
the FSF, visit www.fsf.org.
Other GNU language tools available from Microchip are:
• MPLAB ASM30 Assembler
• MPLAB LINK30 Linker
• MPLAB LIB30 Librarian/Archiver
MPLAB® IDE Simulator, Editor User’s Guide (DS51025)
Refer this document for more information pertaining to the installation and 
implementation of the MPLAB Integrated Development Environment (IDE) software. To 
obtain any of these documents, visit the Microchip web site at www.microchip.com.
© 2008 Microchip Technology Inc. DS51656B-page 5
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THE MICROCHIP WEB SITE 
Microchip provides online support via our web site at www.microchip.com. This web 
site is used as a means to make files and information easily available to customers. 
Accessible by using your favorite Internet browser, the web site contains the following 
information:
• Product Support – Data sheets and errata, application notes and sample 

programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE 
Microchip’s customer notification service helps keep customers current on Microchip 
products. Subscribers will receive e-mail notification whenever there are changes, 
updates, revisions or errata related to a specified product family or development tool of 
interest.
To register, access the Microchip web site at www.microchip.com, click on Customer 
Change Notification and follow the registration instructions.
The Development Systems product group categories are:
• Compilers – The latest information on Microchip C compilers and other language 

tools. These include the MPLAB C18 and MPLAB C30 C compilers; MPASM™ 
and MPLAB ASM30 assemblers; MPLINK™ and MPLAB LINK30 object linkers; 
and MPLIB™ and MPLAB LIB30 object librarians.

• Emulators – The latest information on Microchip in-circuit emulators.This 
includes the MPLAB ICE 2000 and MPLAB ICE 4000.

• In-Circuit Debuggers – The latest information on the Microchip in-circuit 
debugger, MPLAB ICD 2.

• MPLAB® IDE – The latest information on Microchip MPLAB IDE, the Windows® 
Integrated Development Environment for development systems tools. This list is 
focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager 
and general editing and debugging features.

• Programmers – The latest information on Microchip programmers. These include 
the MPLAB PM3 and PRO MATE® II device programmers and the PICSTART® 
Plus and PICkit™ 1 development programmers.
DS51656B-page 6 © 2008 Microchip Technology Inc.
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CUSTOMER SUPPORT 
Users of Microchip products can receive assistance through several channels:
• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support
Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.
Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY 

Revision A (March 2007)
This is the initial release of this document.

Revision B (December 2008)
This revision includes the following updates:
• Figures:

- Updated the note at the bottom right of the device to “Use JP3 to select 
between...” in Figure A-2

- Updated the note to the right of switch SW2 to “Use SW2 to select between...” 
in Figure A-2

- Updated the value of the capacitor C17 to 10 μF in Figure A-2
- Updated the value of pin 28 in J2 to +9V in Figure A-3

• Sections:
- Updated the description in Section 1.6 “UART Communication Via USB”

• Additional minor corrections such as language and formatting updates have been 
incorporated throughout the document
© 2008 Microchip Technology Inc. DS51656B-page 7
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Chapter 1.  Introduction
1.1 INTRODUCTION
The 16-Bit 28-Pin Starter Development Board serves as a development kit and 
evaluation tool for Microchip’s 16-bit digital signal controllers and microcontrollers. 
Topics discussed in this chapter include:
• Development Kit Contents
• Development Board Functionality and Features
• Demonstration Program
• Power Selection
• UART Communication Via USB
• Device Selection
• On-Board Peripheral Selection
© 2008 Microchip Technology Inc. DS51656B-page 9
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1.2 DEVELOPMENT KIT CONTENTS
The 16-Bit 28-Pin Starter Development Board kit consists of the following items:
• Printed circuit 16-Bit 28-Pin Starter Development Board (see Figure 1-1)
• Preprogrammed dsPIC33FJ12GP202 device
• 16-Bit 28-Pin Starter Development Board CD-ROM containing this manual, 16-bit 

documentation and demonstration program code

FIGURE 1-1: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD 

For information on the components used on the 16-Bit 28-Pin Starter Development 
Board, see Chapter 4. “Development Hardware”.
DS51656B-page 10 © 2008 Microchip Technology Inc.



Introduction
1.3 DEVELOPMENT BOARD FUNCTIONALITY AND FEATURES
The 16-Bit 28-Pin Starter Development Board is an easy-to-use tool that allows you to 
start development with dsPIC30F/dsPIC33F and PIC24 devices. Following are the 
important features of the 16-Bit 28-Pin Starter Development Board:
• On-board +5V regulator or +3.3V regulator for VDD and AVDD

• USB power source or 9V DC power source input jack
• Power-on indicator LED

MPLAB ICD 2 Connections
• MPLAB ICD 2 programming connector

UART Communication Channel
• Single UART communication channel via USB bridge

Device Clocking
• 7.37 MHz crystal

Miscellaneous
• Reset push button for resetting the device
• Four LEDs for status indicators
• Push button switch (SW1)
• Potentiometer (RP1) for use with ADC
• All device I/O pins are brought out to a header for test point and prototyping 

access

1.4 DEMONSTRATION PROGRAM
The 16-Bit 28-Pin Starter Development Board is supplied with a preloaded device that 
demonstrates the following board functionality:
• Interrupt handling using Timer1 to toggle the LEDs
• UART functionality using the on-board USB to echo characters sent from a PC 

terminal programmed with a 9600 baud rate
Refer to Chapter 3. “Demonstration Program” for additional information.

1.5 POWER SELECTION
The 16-Bit 28-Pin Starter Development Board has the option of being powered by a 9V 
DC power supply or by the USB bus. The position of jumper JP1 determines which 
power source is used. Connect jumper pins 1 and 2 for the 9V power supply or jumper 
pins 2 and 3 for the USB.
In addition, jumper JP2 selects either +5V or +3.3V power source for the targeted 
device. For dsPIC30F devices, connect jumper pins 1 and 2 for the +5V operation. For 
dsPIC33F and PIC24 devices, connect jumper pins 2 and 3 for the +3.3V operation.
© 2008 Microchip Technology Inc. DS51656B-page 11
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1.6 UART COMMUNICATION VIA USB
The dsPIC30F/dsPIC33F and PIC24 devices use an on-board PIC18 and USB 
interface for UART communications. With switch SW2 in the USB position, the PIC18 
device communicates with the target device through the UART module. The PIC18 will 
then complete the UART-to-USB bridge. The appropriate USB device driver must be 
installed prior to UART-to-USB communication. See Section 2.6.3 “Installing the 
USB Driver” for details.

1.7 DEVICE SELECTION
The position of jumper JP3 determines which family of device 
(dsPIC30F/dsPIC33F/PIC24) to use.

1.8 ON-BOARD PERIPHERAL SELECTION
All on-board peripherals, such as LEDs, potentiometers and the PIC18 (USB bridge), 
can be disconnected from the target devices through JP4, JP5 and SW2, respectively.
DS51656B-page 12 © 2008 Microchip Technology Inc.
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Chapter 2.  Tutorial
2.1 INTRODUCTION
This chapter is a self-paced tutorial to get you started using the 16-Bit 28-Pin Starter 
Development Board. Topics covered in this chapter include:
• Tutorial Overview
• Product Package
• Creating the Project
• Building the Code
• Programming the Chip
• Running the Application
• Debugging the Code
• Programming the Device for Stand-alone Operation
• Summary

2.2 TUTORIAL OVERVIEW
The tutorial program is located on the CD-ROM provided with the development kit, in 
the demo_33F.c file. The tutorial program is written in C code; therefore, the C30 
compiler is required. This program echoes any characters that are sent to the 16-Bit 
28-Pin Starter Development Board from the PC via the USB interface. In addition, the 
program toggles four LEDs. Timer1 is used to create a periodic interrupt, which toggles 
the LEDs.
The source file is used with a linker script file (p33fj12gp202.gld) and a header file 
(p33fj12gp202.h) to form a complete project. This simple project uses a single 
source code file. However, more complex projects might use multiple assembler and 
compiler source files, as well as library files and precompiled object files.

There are four steps to this tutorial:
1. Creating a project in MPLAB IDE
2. Assembling and linking the code
3. Programming the chip with the MPLAB ICD 2
4. Debugging the code with the MPLAB ICD 2

Note: The CD-ROM provided with the development kit also includes tutorial 
programs for dsPIC30F, dsPIC33F and PIC24 devices. This chapter makes 
reference to the files used for dsPIC33F devices only. If you want to apply 
the tutorial to dsPIC30F or PIC24 devices, simply substitute the files 
mentioned in this text with the appropriate device-related file.
© 2008 Microchip Technology Inc. DS51656B-page 13
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2.3 PRODUCT PACKAGE
For this tutorial, you will need the following items:
1. 16-Bit 28-Pin Starter Development Board
2. 9V, 500 mA Plug-in Power Supply with barrel style plug (optional)
3. MPLAB ICD 2 In-Circuit Debugger
4. USB cable
5. PC running Microsoft Windows® with MPLAB IDE 7.52 or later versions
6. MPLAB C30 Compiler

2.4 CREATING THE PROJECT
The first step is to create a project and a workspace in MPLAB IDE. In any particular 
folder one project and one workspace are present.

A project contains the files that are used to build an application (source code, linker 
script files, and so on) along with their association to various build tools and build 
options.
The workspace consists of the following features:
• One or more projects
• Information on the selected device
• Debug tool and/or programmer, open windows and their location
• Other MPLAB IDE configuration settings
MPLAB IDE contains a Project Wizard to help create new projects. Before starting, 
create a folder for the project files for this tutorial (C:\Tutorial is assumed in the 
instructions that follow). From the Example Code directory on the 16-Bit 28-Pin Starter 
Development Board Kit CD, copy the demo_33F.c file into the C:\Tutorial folder. 

2.4.1 Select a Device
1. Start MPLAB IDE.
2. Close any workspace that might be open (File>Close Workspace).
3. From the Project menu, select Project Wizard.
4. On the Welcome screen, click Next > to display the Project Wizard Step One 

dialog (see Figure 2-1).
DS51656B-page 14 © 2008 Microchip Technology Inc.
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FIGURE 2-1: PROJECT WIZARD STEP ONE: SELECT A DEVICE

5. From the Device: drop-down list, select dsPIC33FJ12GP202 and click Next >. 
The Project Wizard Step Two dialog appears.

FIGURE 2-2: PROJECT WIZARD STEP TWO: SELECT A LANGUAGE 
TOOLSUITE
© 2008 Microchip Technology Inc. DS51656B-page 15
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2.4.2 Select a Language Toolsuite
1. From the Active Toolsuite: drop-down list, select Microchip C30 Toolsuite. 

This toolsuite includes the compiler and linker that will be used. 

2. Click Next > to continue. The Project Wizard Step Three dialog appears.

FIGURE 2-3: PROJECT WIZARD STEP THREE: NAME YOUR PROJECT

2.4.3 Name Your Project
1. In the Project Name text box, type MyProject.
2. Click Browse... and navigate to C:\Tutorial\ to place your project in the 

Tutorial folder.
3. Click Next > to continue. The Project Wizard Step Four dialog appears.
DS51656B-page 16 © 2008 Microchip Technology Inc.
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FIGURE 2-4: PROJECT WIZARD STEP FOUR: ADD FILES TO PROJECT 

2.4.4 Add Files to the Project
1. Locate the C:\Tutorial folder and select the demo_33F.c file.
2. Click Add >> to include the file in the project.
3. Expand the C:\Program Files\Microchip\MPLAB C30\support\gld 

folder and select the p33fj12gp202.gld file.
4. Click Add >> to include this file in the project. There should now be two files in 

the project. 
5. Click Next > to continue.
6. When the summary screen appears, click Finish.
Now, the MPLAB IDE project window shows the demo_33F.c file in the Source Files 
folder, and the p33fj12gp202.gld file in the Linker Scripts folder (see Figure 2-5).
© 2008 Microchip Technology Inc. DS51656B-page 17
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FIGURE 2-5: MPLAB® IDE PROJECT WINDOW

A project and workspace have now been created in MPLAB IDE. MyProject.mcw is 
the workspace file and MyProject.mcp is the project file. Double-click the 
demo_33F.c file in the project window to open the file.
DS51656B-page 18 © 2008 Microchip Technology Inc.
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2.5 BUILDING THE CODE
1. From the Project menu select Build All. The Build Output window appears.

FIGURE 2-6: BUILD OUTPUT WINDOW 

2. Observe the progress of the build.
3. When the BUILD SUCCEEDED message appears, you are ready to program the 

device.
© 2008 Microchip Technology Inc. DS51656B-page 19
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2.6 PROGRAMMING THE CHIP
The MPLAB ICD 2 In-Circuit Debugger can be used to program and debug the device 
on the 16-Bit 28-Pin Starter Development Board. For this demonstration, we will use 
the Debug option. From the MPLAB IDE main screen, click the drop-down list and 
change Release to Debug. 

Use the following MPLAB IDE procedures to program the dsPIC30F/33F and PIC24 
devices.

2.6.1 Setting Up the Device Configuration
Use the Configure>Configuration Bits menu to display the configuration settings. The 
Configuration Bits window is shown in Figure 2-7.
The device Configuration bits determine global device operating parameters, such as 
clock source, brown-out threshold voltage and so on. For this code example, the 
following configuration settings will be defined:
• The oscillator source will be set to internal FRC with PLL
• The primary oscillator will be disabled
• The Watchdog timer will be disabled
Using these configuration settings will ensure that the device runs at maximum speed.

FIGURE 2-7: CONFIGURATION SETTINGS

Note: Before proceeding, ensure that the USB driver for the MPLAB ICD 2 has 
been installed on your PC. Refer to the “MPLAB® ICD 2 User’s Guide” 
(DS51331) for more details regarding the installation of the MPLAB ICD 2. 
DS51656B-page 20 © 2008 Microchip Technology Inc.
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2.6.2 Selecting the MPLAB ICD 2 Communication Pins
All dsPIC30F/33F and PIC24 devices use a pair of I/O pins (PGCx/EMUCx and 
PGDx/EMUDx) for initially loading your application program into the device, and for 
communicating with the MPLAB ICD 2 In-Circuit Debugger. Typically, these pins can 
be used by your application program for other functions after your program is loaded 
into the device. However, the application functions are not available while you are 
connected to the MPLAB ICD 2 for debugging.
To avoid this issue, most dsPIC30F/33F and PIC24 devices use one or more sets of 
alternate pins for MPLAB ICD 2 communication. These alternate pins are identified as 
EMUCx and EMUDx, where x designates the number of the pin pair. By selecting an 
alternate set of pins for the MPLAB ICD 2, you can safely use the original I/O pins for 
your application.
For this development board, the pin pairs, PGCx/EMUCx, on device pins 4, 5, 11 and 
12 are used for debugging.   

To select the MPLAB ICD 2 communication pins: 
1. On the Configuration Bits screen (Figure 2-7), move to the Comm Channel 

Select category.
2. In the Setting column, set the parameter to Use PGC1/EMUC1 and 

PGD1/EMUD1.

2.6.3 Installing the USB Driver
1. Connect the power supply to the board. Refer to Section 1.5 “Power Selection” 

for details.
2. Select the dsPIC33F device configuration. Refer to Section 1.7 “Device 

Selection” for details.
3. Connect the 16-Bit 28-Pin Starter Development Board to the PC with the USB 

cable. The Found New Hardware Wizard dialog appears as shown in Figure 2-8.

Note: SW2 must be switched to the “Program” position for dsPIC30F devices 
when the application is being programmed into a device with MPLAB ICD 2. 
Once the programming is complete, SW2 must be switched back to the 
“USB/Debug” position for UART communication via the USB bridge. See 
Figure 4-1 for the location of this switch.
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FIGURE 2-8: FOUND NEW HARDWARE WIZARD

4. Select No, not this time, then click Next > to continue. The Select Installation 
Location dialog appears.

5. Select install from a list or specific location, then click Next > to continue. The 
Search and Installation Options dialog appears as shown in Figure 2-9.
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FIGURE 2-9: SEARCH AND INSTALLATION OPTIONS

6. Select the Search for the best driver in these locations radio button, and then 
select the Search removable media (floppy, CD-ROM) check box, and then 
click Next > to continue.

7. Windows installs the USB driver. Select Finish to close the Found New 
Hardware Wizard.

2.6.4 Connecting the MPLAB ICD 2 In-Circuit Debugger
1. Connect the MPLAB ICD 2 to the PC with the USB cable.
2. Connect the MPLAB ICD 2 to J4 on the 16-Bit 28-Pin Starter Development Board 

with the short RJ-11 (telephone) cable.
3. For dsPIC30F devices only, verify that SW2 is in the “Program” position.

Note: Before continuing to the next step, make sure that the 16-Bit 28-Pin Starter 
Development Board CD-ROM is inserted in the CD-ROM drive.
© 2008 Microchip Technology Inc. DS51656B-page 23



16-Bit 28-Pin Starter Development Board User’s Guide
2.6.5 Enabling the MPLAB ICD 2 Connection
1. From the Debugger menu, click Select Tool>MPLAB ICD 2 to designate the 

MPLAB ICD 2 as the debug tool in MPLAB IDE.
2. From the Debugger menu, select Connect to connect the debugger to the device. 

The MPLAB IDE should report that it found the device, as shown in Figure 2-10.

FIGURE 2-10: ENABLING MPLAB® ICD 2 

2.6.6 Programming the Device

From the Debugger menu, select Program to program the part. The output window 
(Figure 2-11) displays the program status as they appear. 

Note: MPLAB IDE may need to download new firmware if this is the first time the 
MPLAB ICD 2 is being used with a dsPIC30F device. Allow it to do so. If 
any errors are shown, double click the error message to get more 
information.

Note: SW2 must be switched to the “Program” position for dsPIC30F devices 
when the application is being programmed into a device with MPLAB ICD 2. 
Once programming is complete, SW2 must be switched back to the 
“USB/Debug” position for UART communication via the USB bridge. See 
Figure 4-1 for the location of this switch.
DS51656B-page 24 © 2008 Microchip Technology Inc.



Tutorial
FIGURE 2-11: PROGRAMMING THE DEVICE

2.7 RUNNING THE APPLICATION

2.7.1 Configuring the UART-to-USB Connection
1. On the PC, right-click My Computer and select Properties.
2. Select the Hardware tab and click Device Manager.
3. In the Ports group, verify that an additional COM port is mapped. This COM port 

is from the PCB to the PC, and will used in the Windows® HyperTerminal 
demonstration.

4. Open the HyperTerminal program from the CD-ROM and select the 
File>Properties menu and verify that the correct COM port is selected for the 
USB cable from the PCB.
The COM settings for this port are: 9600 bits per second, no parity, eight data bits 
and one stop bit. When a character is entered on the keyboard, it should be 
echoed, enclosed in quotes (i.e., input a, output “a”) on the HyperTerminal 
display when the demonstration program is running.

2.7.2 Executing the Application

Select Debugger>Run to execute the code. All four LEDs on the development board 
should start blinking twice per second. (If using a dsPIC30F device, switch SW2 to USB 
after executing the code.)

Note: SW2 must be switched to the “Program” position for dsPIC30F devices 
when the application is being programmed into a device with MPLAB 
ICD 2. Once programming is complete, SW2 must be switched back to the 
“USB/Debug” position for UART communication via the USB bridge. See 
Figure 4-1 for the location of this switch.
© 2008 Microchip Technology Inc. DS51656B-page 25



16-Bit 28-Pin Starter Development Board User’s Guide
2.8 DEBUGGING THE CODE
The MPLAB ICD 2 In-Circuit Debugger can be used to run, halt and step the code. A 
breakpoint can be set to halt the program once the code has executed the instruction 
at the breakpoint. The contents of the RAM and registers can be viewed whenever the 
processor has been halted.
The MPLAB ICD 2 In-Circuit Debugger uses the following function keys to access the 
main debugging functions:
• <F5> Halt
• <F6> Reset
• <F7> Single Step
• <F9> Run
In addition, there are more functions available by right clicking on a line of source code. 
The most important of these are Set Breakpoint and Run to Cursor.

2.8.1 Displaying the Code
1. From the View menu, select Program Memory.
2. In the Program Memory window, select the Symbolic tab, as shown in 

Figure 2-12.

FIGURE 2-12: PROGRAM MEMORY WINDOW 

3. Press <F5> to halt the processor and press <F6> to reset the processor. The 
program memory now displays a green arrow pointing to the line of code at 
address 00000, which is the reset location. 
The instruction at this location is goto_reset. This code is added by the linker 
to make the program branch to the start of the code in the demo_33F.c file.
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2.8.2 Stepping the Program
1. After halting the program, press <F7> to single-step the code. Observe the 

location of the green arrow while single stepping. In this demonstration, the code 
will halt in the while loop of the UART, as shown in Figure 2-13.

FIGURE 2-13: SOURCE CODE WINDOW 

2. Right-click the line of code, LATE ^= 0xF;, and select Run to Cursor. The 
green arrow moves to the bracket below the line of code because it has executed 
the prior lines of code up to and including LATE ^= 0xF;.

3. From the View menu, select Watch to open a Watch window.
4. From the Add SFR pull-down list, display PC.
5. Click Add SFR to add the PC register to the Watch window.
6. Press <F7> a few times and watch the PC value increment (see Figure 2-14). PC 

is the repeat loop counter that increments with each step.

FIGURE 2-14: WATCH WINDOW DISPLAY 
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2.8.3 Setting the Breakpoint
1. To set a breakpoint, right-click a line of code and select Set Breakpoint from the 

pop-up menu. 

As an example, find the following line of code and set a breakpoint on this line:
IFS0bits.T1IF = 0;

A red stop sign appears in the gutter (gray bar on the left) of the source code 
window. 

2. Press <F6> to reset the device, then <F9> to execute the code. The program 
halts on the instruction next to the breakpoint as shown in Figure 2-15. When 
MPLAB ICD 2 is halted, the next instruction is executed. Observe that the LEDs 
on the development board remain lit.

FIGURE 2-15: SETTING BREAKPOINT 

Note: An alternate method is to simply double-click the line. This feature may 
need to be enabled using the Edit>Properties menu. 

Note: The instruction on which the code halts could be elsewhere in the code if 
the breakpoint is set on a branch or call instruction. Refer to Section 12. 
“Important Notes” in the readme file, MPLAB ICD 2.txt located in the 
C:\MPLAB IDE\READMES directory for operational information on the 
MPLAB ICD 2.
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2.9 PROGRAMMING THE DEVICE FOR STAND-ALONE OPERATION
The previous example provided the basics of code debugging using the MPLAB ICD 2. 
When you have fully debugged your application, you will want to run the code without 
using the MPLAB ICD 2. In the following example, the MPLAB ICD 2 is enabled as a 
device programmer instead of a debugger.
1. Starting with the project you have created in this tutorial, select MPLAB ICD 2 as 

the device programmer. From the Programmer menu, select the 
Select Programmer>MPLAB ICD 2 option. 
If you were previously using the MPLAB ICD 2 as a debugger tool, you will 
receive a warning message indicating that the tool cannot be enabled as a 
programmer and a debugger at the same time. Click OK in the warning message 
to continue.

2. From the Program menu, select Program option to program the part. The output 
window will look similar to Figure 2-11, except that the debugging features of the 
device will not be enabled.

3. Remove the MPLAB ICD 2 programming cable connected to J4. When the cable 
is unplugged, the device begins to run the application.

2.10 SUMMARY
This tutorial demonstrates the main features of the MPLAB IDE and MPLAB ICD 2 as 
they are used with the 16-Bit 28-Pin Starter Development Board. Upon completing this 
tutorial, you should be able to:
• Create a project using the Project Wizard
• Set the Configuration bits
• Set up MPLAB IDE to use the MPLAB ICD 2 In-Circuit Debugger
• Program the chip with the MPLAB ICD 2
• View the code execution in program memory and source code
• View registers in a Watch window
• Set a breakpoint and make the code halt at a chosen location
• Use the function keys to reset, run, halt and single step the code
• Program the device for Debugger mode or stand-alone operation

Note: SW2 must be switched to the “Program” position for dsPIC30F devices 
when the application is being programmed into a device with MPLAB 
ICD 2. Once programming is complete, SW2 must be switched back to the 
“USB/Debug” position for UART communication via the USB bridge. See 
Figure 4-1 for the location of this switch.
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Chapter 3.  Demonstration Program
3.1 INTRODUCTION
This chapter provides an overview of the 16-Bit 28-Pin Starter Development Board 
demonstration program. Hardware information of the 16-Bit 28-Pin Starter 
Development Board hardware is presented in Chapter 4. “Development Hardware” 
and Appendix A. “Drawings and Schematics”.
Topics discussed in this chapter include:
• Demonstration Program Summary
• Demonstration Program Description
• Demonstration Program Setup

3.2 DEMONSTRATION PROGRAM SUMMARY
The 16-Bit 28-Pin Starter Development Board is shipped along with a simple demo 
application programmed into the dsPIC33FJ12GP202 device. This program 
demonstrates the use of key functionality.

3.3 DEMONSTRATION PROGRAM DESCRIPTION
When power is applied to the 16-Bit 28-Pin Starter Development Board, the device 
starts executing the demonstration program. The program demonstrates the following 
functions: 
• UART Communication
• Timer Interrupt

3.3.1 UART Communication
The program uses the UART peripheral to communicate with the PC HyperTerminal 
application via the on-board UART-to-USB bridge. The program waits for the character 
to be received from the PC, and echoes it back to the PC enclosed in quotes.

3.3.2 Timer Interrupt
To illustrate interrupt processing, the demonstration program uses Timer1 to generate 
interrupts, which cause the LEDs to blink. The clock prescaler and period register for 
Timer1 are configured to produce an interrupt on every 250 ms.
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3.4 DEMONSTRATION PROGRAM SETUP

3.4.1 Installing the USB Driver
1. Connect the power supply to the board. Refer to Section 1.5 “Power 

Selection” for details.
2. Select the dsPIC33F device configuration. Refer to Section 1.7 “Device 

Selection” for details.
3. Connect the 16-Bit 28-Pin Starter Development Board to the PC with USB cable. 

The Found New Hardware Wizard dialog appears as shown in Figure 3-1.

FIGURE 3-1: FOUND NEW HARDWARE WIZARD

4. Select No, not this time, and then click Next > to continue.
5. Select install from a list or specific location, then click Next > to continue. The 

Found New Hardware Wizard, Search and Installation Options dialog appears as 
shown in Figure 3-2.
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FIGURE 3-2: SEARCH AND INSTALLATION OPTIONS

6. Select the Search for the best driver in these locations radio button, and then 
select the Search removable media (floppy, CD-ROM) check box, now click 
Next > to continue.

7. Windows installs the USB driver. Select Finish to close the Found New 
Hardware Wizard.

3.4.2 Configuring the UART-to-USB Connection
1. On the PC, right-click My Computer and select Properties.
2. Select the Hardware tab, and click Device Manager.
3. In the Ports group, verify that an additional COM port is mapped. This COM port 

is from the PCB to the PC and is used in the HyperTerminal demonstration.
4. Open the HyperTerminal program from the CD-ROM, select the File>Properties 

menu and verify that the correct COM port is selected for the USB cable from the 
PCB.
The COM settings for this port are: 9600 bits per second, no parity, eight data bits 
and one stop bit. When a character is entered on the keyboard, it should be 
echoed enclosed in quotes (i.e., input a, output “a”) on the HyperTerminal display 
when the demonstration program is running.

Note: Before continuing to the next step, make sure that the 16-Bit 28-Pin Starter 
Development Board CD-ROM is inserted in the CD-ROM drive.
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Chapter 4.  Development Hardware
4.1 INTRODUCTION
This chapter describes the 16-Bit 28-Pin Starter Development Board hardware under 
the following topics:
• Hardware Overview
• Hardware Elements

4.2 HARDWARE OVERVIEW
The numbered board components are described in Table 4-1.

FIGURE 4-1: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD
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TABLE 4-1: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD HARDWARE 
ELEMENTS

4.3 HARDWARE ELEMENTS

4.3.1 USB Port (J3)
The 16-Bit 28-Pin Starter Development Board provides one USB communication 
channel. The USB communication channel is labeled J3. The device communicates 
using the UART to the on-board PIC18 through the U1RX and U1TX pins, which then 
communicates through the USB port. The USB port can also be used to power the 
development board.

4.3.2 MPLAB ICD 2 Connector (J4)
By way of this modular connector, the MPLAB ICD 2 can be connected for low-cost 
programming and debugging of the device.

4.3.3 Power Supply Connector (J1)
The 16-Bit 28-Pin Starter Development Board can be powered by a 9V AC/DC wall 
adapter with a standard 2.1 mm barrel plug.

4.3.4 Power-on Indicator (D3)
A green LED is connected to the output of the regulators to indicate the presence of 
power.

4.3.5 +5V or +3.3V Jumper (JP2)
This jumper is used at +5V when a dsPIC30F family device is being used, and at +3.3V 
when a dsPIC33F or PIC24 family device is being used. 

4.3.6 Power Supply or USB Jumper (JP1)
This jumper allows the circuit to be powered by a 9V power supply (J1) or by the USB 
port (J3).

No. Name Description

1 J3 USB Port
2 J4 MPLAB® ICD 2 Connector
3 J1 Power Supply Connector
4 D3 Power-on Indicator
5 JP2 +5V or +3.3V Jumper
6 JP1 Power Supply or USB Jumper
7 D4-D7 LED Indicators
8 JP4 LED Connect Jumper
9 RESET Reset Button
10 SW1 Switch 1
11 SW2 Switch 2
12 RP1 Potentiometer
13 JP5 Potentiometer Connect Jumper
14 Y1 Oscillator
15 JP3 Device Selection Jumper
16 J2 I/O Header
17 J6 PICkit™ 2 Connector
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4.3.7 LED Indicators (D4-D7)
LEDs are connected to the device for user operations.

4.3.8 LED Connect Jumper (JP4)
If removed, this jumper restricts the use of the LEDs.

4.3.9 Reset Button (RESET)
The MCLR Reset button is connected to the processor MCLR pin, which provides a 
hard Reset to the device.

4.3.10 Switch 1 (SW1)
This switch is connected to the devices for user operations.

4.3.11 Switch 2 (SW2)
This switch, when used with a dsPIC30F family device, programs the device to 
communicate with the PC via USB. If you are using a dsPIC33F or PIC24 family device, 
this switch should be in the USB position at all times.

4.3.12 Potentiometer (RP1)
This potentiometer is connected to the device for the use of the ADC peripheral.

4.3.13 Potentiometer Connect Jumper (JP5)
This jumper allows the use of the potentiometer. 

4.3.14 Oscillator (Y1)
A crystal oscillator (7.37 MHz) is supplied. The crystal oscillator can be used with the 
on-chip PLL circuit to provide internal instruction execution frequencies.

4.3.15 Device Selection Jumper (JP3)
This jumper determines whether the dsPIC30F or dsPIC33F/PIC24 device is used. 

4.3.16 I/O Header (J2)
All device I/O pins are brought out to this header for test points and prototyping access.

4.3.17 PICkit™ 2 Connector (J6)
By way of this modular connector, the PICkit 2 can be connected for low cost 
programming and debugging of the device.
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Appendix A. Drawings and Schematics
A.1 INTRODUCTION
This appendix contains the following layouts and schematics for the 16-Bit 28-Pin 
Starter Development Board:
• 16-Bit 28-Pin Starter Development Board Layout
• 16-Bit 28-Pin Starter Development Board Schematics

A.2 16-BIT 28-PIN STARTER DEVELOPMENT BOARD LAYOUT

FIGURE A-1: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD LAYOUT

h
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A.3 16-BIT 28-PIN STARTER DEVELOPMENT BOARD SCHEMATICS

FIGURE A-2: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD SCHEMATIC (SHEET 1 OF 2)
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FIGURE A-3: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD SCHEMATIC (SHEET 2 OF 2)
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Appendix B. Bill of Materials (BOM)
TABLE B-1: BILL OF MATERIALS

Qty Component Name Reference Value Vendor Vendor P/N

1 CAP-CRCW0805 C17 1 µF Digi-Key PCC2249CT-ND
5 CAP-CRCW0805 C1 10 µF Digi-Key 490-3886-1-ND

C3 10 µF
C4 10 µF
C5 10 µF
C11 10 µF

4 CAP-CRCW0805 C6 20 pF Digi-Key 478-3735-1-ND
C7 20 pF

C14 20 pF
C15 20 pF

8 CAP-CRCW0805 C2 100 nF Digi-Key PCC1864CT-ND
C8 100 nF
C9 100 nF

C10 100 nF
C12 100 nF
C13 100 nF
C16 100 nF
C18 100 nF

1 CNN-POWER-IN-MOD-2.5MM J1 2.5 MM Digi-Key CP-102BH-ND
1 CNN-RJ11-ICSP-6-PIN-PTH J4 RJ11-6-pin Digi-Key A31417-ND
1 CNN-USB-TYPE-B-PTH J3 USB Digi-Key A31725-ND
2 DIO-1N4148WS-SOD-323 D1 1N4148 Digi-Key 1N4148WS-FDICT-ND

D2 1N4148
4 FOOT-BUMPON-RUBBER-0.375-ROUND BOM1 BUMPON Digi-Key RBS-12-ND

BOM2
BOM3
BOM4

1 HDR-2X14-IC-STYLE J2 HEADER Digi-Key 929665-09-36-ND
1 ICP-DUAL-PIC-28-PIN-SDIP U1 dsPIC33F MCHP dsPIC33F
1 ICP-PIC18F2450/ML-QFN-28-PIN-6X6MM U2 PIC18F2450/ML MCHP PIC18F2450/ML
1 IND-1210 L1 60Ω Digi-Key 240-2416-1-ND
2 JMP-2PIN-VIAS JP4 1x2 Jameco 108337

JP5 1x2
3 JMP-3PIN-CFG2-VIAS JP1 1x3 Jameco 109575

JP2 1x3
JP3 1x3

1 LED-LTST-C150XKT-1206-SMD D3 GRN Digi-Key 160-1169-1-ND
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4 LED-LTST-C150XKT-1206-SMD D4 RED Digi-Key 160-1167-1-ND
D5
D6
D7

1 POT-3352E-BOURNS-1T RP1 10K Digi-Key 3352E-103LF-ND
2 RES-CRCW0805 R9 1K Digi-Key RHM1.00KCCT-ND

R13 1K
1 RES-CRCW0805 R6 1M Digi-Key RHM1.00MCCT-ND
2 RES-CRCW0805 R10 10 Digi-Key RHM10.0CCT-ND

R11 10
3 RES-CRCW0805 R7 10K Digi-Key RHM10.0KCCT-ND

R8 10K
R12 10K

5 RES-CRCW0805 R1 475 Digi-Key RHM475CCT-ND
R2 475
R3 475
R4 475
R5 475

2 SWT-B3F1000-MOM-NO-PTH SW3 RESET Digi-Key SW402-ND
SW1 MOM-NO

1 SWT-E-SWT-EG2209-VERT-PTH SW2 PROGRAM Digi-Key EG1907-ND
1 TSP-P90R60 TP2 +3.3V - WHI Digi-Key 5012K-ND
1 TSP-P90R60 TP1 +5V - RED Digi-Key 5010K-ND
1 TSP-P90R60 TP6 AGND - ORN Digi-Key 5013K-ND
1 TSP-P90R60 TP5 AVDD - YEL Digi-Key 5014K-ND
2 TSP-P90R60 TP3 GND - BLK Digi-Key 5011K-ND

TP4 GND - BLK
1 VRG-LM2937IMP-SOT223-SMT VR1 +5V Digi-Key LM2937IMP-5.0CT-ND
1 VRG-TC1262IMP-SOT223-SMT VR2 +3.3V MCHP TC1262-3.3VDBTR
1 XTL-200LS-PTH-CAN Y1 7.3728 MHz Digi-Key X1084-ND
1 XTL-ABM8-SMT Y2 20.0 MHz Digi-Key 535-9136-1-ND
1 SOC-PIC-28-PIN-SDIP SU1 SOCKET Digi-Key ED90054-ND
1 PCB-DSPICDEM-28-PIN-PLUS-DEMO PCB1 BLANK PCB — —
5 SHUNT, 2-PIN SH1-5 — Jameco 421454

TABLE B-1: BILL OF MATERIALS (CONTINUED)

Qty Component Name Reference Value Vendor Vendor P/N
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